Error activating feature

Jun 28, 2012 at 11:49 AM

Hi

 

Firstly, I saw the thread about the same issue....

 

 

When I deploy EF Workflow Timer via the Install.bat script (in a cmd with admin rights), I can't activate the feature - access denied. This is on sppersistedobject (some sort of update or web.config modification I believe). This is a documented problem, but I can't find a fix in the context of activating this feature. What can I do? :(

Coordinator
Jul 5, 2012 at 12:45 PM
Edited Jul 5, 2012 at 12:49 PM

Hi GSS5,

You have a few options:

1. Join your user account to SQL Server Server Role "sysadmin";

2. Or, you can log on as SharePoint Setup account, then deploy this solution;

3. If step 1 and 2 doesn't work, then please follow the link below, to turn off "RemoteAdministratorAccessDenied"

http://support.microsoft.com/kb/2564009

function Set-RemoteAdministratorAccessDenied-False()
{
    [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint") > $null
    [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint.Administration") > $null

    # get content web service
    $contentService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    # turn off remote administration security
    $contentService.RemoteAdministratorAccessDenied = $false
   $contentService.Update()         
}

Set-RemoteAdministratorAccessDenied-False

Then perform an IISReset

Then you can try to deploy this workflow timer solution.

Mar 19, 2013 at 1:11 PM
Edited Mar 19, 2013 at 1:11 PM
I have a SP Farm with multiple site collections. This solution deployed and activated perfectly for the main (root) site collection, but I can not activate it for any other site collection, I receive the error:

The feature could not be activated. ex.Message=The EXECUTE permission was denied on the object 'proc_putObject', database 'content.db', schema 'dbo'

None of the suggested solutions above resolve the issue (tried all of them but the console). The powershell code executed without error, but it didn't resolve the issue.

Any suggestions?

Thanks,
Larry
Coordinator
Mar 19, 2013 at 10:51 PM
Edited Mar 19, 2013 at 10:52 PM
Larry,

Try freeware "HarePoint Workflow Scheduler", it's much better. This open source project is mainly for learning purpose.
Mar 20, 2013 at 7:25 PM
"HarePoint Workflow Scheduler" is better ? not good for me,when i test it ,sp farm crash.......
Sep 10, 2013 at 8:13 PM
I had the same problem trying to activate through Site Settings > Site Collection Features. Was able to activate using SharePoint Management Shell on the WFE.

Enable-SPFeature -Identity ef_efworkflowtimer -Url YOURURL