Error EFWorkflowTImer

Apr 13, 2012 at 10:02 AM

I have two lists: List1 and List2. A workflow is running on the list1 EFWorkflowTimer, this is a validation in the workflow database and creates a new item in list2. But get this error:

Exception.StackTrace= at EF.EFWorkflowTimer.logWorkflowTimerHistory(SPWeb objSPWeb, SPListItem itemTarget, String strMessage)
at EF.EFWorkflowTimer.processOneJobitem(SPWeb objSPWebRoot, SPListItem objTimerItem)

Exception.Message=Object reference not set to an instance of an object.

Exception.Message=Object reference not set to an instance of an object.

Exception.Message=Invalid text value.

A text field contains invalid data. Please check the value and try again.

 

Hug

Coordinator
Apr 13, 2012 at 10:37 AM

Hi Hug,

Could you run your workflow manually?   If it works well, then I need to check your timer settings for further details.

 

By the way, I like your name  :-)

 

Eric

Apr 13, 2012 at 1:07 PM

 

Hi,

 

yes, the workflow run well if runs manually.

Here is my configuratuions:

Open Menu
Minutes List WF ValidateTypeAccount (CreateFoldersProspect-Client)   Lists/ValidateTypeAccount/AllItems.aspx Yes Yes Yes 4/13/2012 12:57 PM
0

 

Hug

Coordinator
Apr 13, 2012 at 1:13 PM

Sorry, I cannot tell it.

What's the workflow name and web url ?

Apr 13, 2012 at 1:16 PM

 

The workflow name is: WF ValidateTypeAccount (CreateFoldersProspect-Client);

I don´t specified any web url, because this is a List workflow.

 

Coordinator
Apr 13, 2012 at 1:20 PM

Could you give the workflow a short name? Such as "wfTest1".

Apr 13, 2012 at 1:25 PM

Ok, i do that.

Another issue:

 imagine the same two lists, and I have a workflow to be run through WFWorkflowTimer in list1. This workflow creates an item in List2, in the  List2 ihave a workflow to run when a new item is created. However, whenever I'm using EFWorkflowTimer the workflow in list2  never starts.

Is there something in the code that does not allow trigger workflows that have run through WFWorkflowTimer?

Coordinator
Apr 13, 2012 at 1:37 PM
Edited Apr 13, 2012 at 1:37 PM

SharePoint workflow is not supposed to be triggered by code .... However, I didn't test that on purpose.

Normally we can move the process of the 2nd workflow into the 1st workflow, then delete the 2nd workflow (or don't let it be triggered when new item is created)

Apr 13, 2012 at 1:40 PM

 

I changed the name of my workflows, but still not started.

Apr 13, 2012 at 1:43 PM

 

I made the post I was referring to when a workflow is executed in list1 through EFWorkflowTimer, and that this workflow creates a new item in List2. In List2 is that there is a workflow associated with this list whenever a new item is created it runs.

Coordinator
Apr 13, 2012 at 1:43 PM

Sorry mate, need to debug the code to figure it out...

Apr 13, 2012 at 2:18 PM

 


the workflow associated with list1, which is being run through the EfWorkflowTimer. This workflow is created in SP Designer 2010, and I'm running an action that allows me to run SQL commands into a database.Does this action because it gives me error?

Apr 16, 2012 at 9:23 PM

Hi,

 

i can run a workflow using the Workflow Timer EF only within a Document Library that contains folders and subfolders and the workflow is executed for all items in these folders and subfolders?

 

Hug

Coordinator
Apr 17, 2012 at 1:05 AM
Edited Apr 17, 2012 at 1:40 PM

It should be able to process all items in specified list view. If it doesn't, then that's a bug.

During my test, it works well with or without sub folders.


Apr 17, 2012 at 8:13 AM

Hi,

I have a library that has a documetos folders and subfolders within subfolders within the documents. The workflow through the Workflow EF timer runs only at the folder level.

Do you think there is way to solve this?

 

Hug

Coordinator
Apr 17, 2012 at 11:33 AM
Edited Apr 17, 2012 at 1:40 PM

Hug,

If you don't mind, could you send me the site collection backup?
If I can reproduce the same error, then I can fix it.
Apr 17, 2012 at 1:15 PM

 

You can give me your email address to send you the attach the backup?

Coordinator
Apr 17, 2012 at 2:05 PM

could you tell me the exact version number of your sharepoint server?

And, sorry for saying that, the trouble shooting may take a few days, is that all right?

Apr 17, 2012 at 2:07 PM
My site collection is: http://myp-087/default.aspx

No problem fangdahai.

hug